Unable to enable debug logs in Octopus

I am not able to enable debug logs in octopus. I am using octopus version v2022.3.

Attached is the Octopus.Server.exe.nlog" file. I have already enabled trace log in the config file. Still I octopus is printing only “INFO” level logs. Can you please suggest?

Octopus.Server.exe.nlog (2.1 KB)

Hey Rahul,

Thanks for reaching out and for the information.

Taking a look at your config, it looks okay to me. Are you by chance running HA nodes? If so, can you please try and enable the same log level over on the other nodes and let me know if it helps?


Thanks for responding. We do not have HA nodes. We have only one node.


Hi Rahul,
Just stepping in for Jeremy who is offline as part of our US team.

In fact you are right, things have changed on the logging front. I have verified the changes happened in your version and rnow equires setting an OS level change to use the TRACE logging functionality.

To set TRACE now, you will need to set a normal user level OS variable:

You can also go a step further and send all low-level events by default to the nlog file by setting this variable:
(this one may be a bit too much for other logging interfaces though so YMMV on that one)

Pls note an Octopus server service restart is required to enable this.

Apologies that the online docs have not caught up with this change as of yet. I will request they get updated.

Kind regards,


Thanks for your response.

We are running octopus as a windows service. The octopus is running as user “octopus”. I have logged in to the windows server running octopus deploy, using user “octopus”. Then setup the user variable suggested by you (pls find the screenshot attached) . Also, restarted the octopus . I am still not getting trace logs

can you please help? I need to get the trace logs to troubleshoot issues related to AD integration.

Hey Rahul,

I think the issue is that in your environment variable you have 1 underscore when each section needs 2 like __, not _. It’s a bit confusing, sorry about that.

Please let me know if changing that and restarting the service works for you.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.