Unable to deploy Cloudformation Stack using SSH Worker

reliability
(DealerSocket Deployment) #1

ServerTasks-755258.log.txt (5.9 KB)

See Raw log attached

SSH Worker is running CentOS 7. All requisite setup was completed as per Octopus documentation

(Justin Walsh) #3

Hi @DealerSocketDeployment!

Thanks for getting in touch, and sorry to hear that you’re having issues here. From the looks of the error, it isn’t able to load the calamari executable on your system. I did have a couple of questions here to see if we can get to the bottom of this:

  • Which version of Calamari do you have configured in your SSH Deployment target - Self-contained or Calamari on Mono?
  • If you attempt to run calamari.exe manually via SSH, do you get any more information as to why it’s not working?

Hope to hear from you soon!

(DealerSocket Deployment) #4

Hello Justin –

Apologies for the delayed response. Adding my colleague Brian to the conversation. I have attached the output of a Health Check on this worker reflecting Calamari v.4.10.0 . I have also attached a screen capture of the target settings configuration.

As for gleaning additional information running the Calamari.exe on the target, I’ve attached deploy log after running the following on the worker from the Octopus Script Console.

/home/svcworker/.octopus/OctopusServer/Calamari/Cloud/4.10.0/Calamari.exe

Is there a different/better way that you would recommend me running Calamari.exe on that target? Any advice is welcomed.

Thank you,

(Health Check) ServerTasks-765187.log.txt (2.9 KB)

(Script Console) ServerTasks-765217.log.txt (3.4 KB)