Unable to create a polling tentacle in Octopus Deploy

I am trying to create a Polling Tentacle in Octopus Deploy but I am getting an error.
I want to create a tentacle with a proxy but I am having issue trying first with no proxy.
It is failing on the register worker step.
Checking connectivity on the server communications port 10943.
We created a new VIP for Octopus to allow ingress on port 10943 on downstream Octopus nodes.
Not sure why its failing? Any help would be appreciated.

I have attached the log minus some sensitive information.
PollingTentacleIssuesLog.txt (8.5 KB)

Kind Regards,
Micheál Power

Hi @mikepower79

As part of this process, we reach out to the Octopus server API to perform the call to register the tentacle, is TCP/443 (or TCP/80 if you’re not using HTTPS) open between the target and Octopus server as well as TCP/10943?

Hi @Justin_Walsh,
I have tried to create a Polling Tentacle on one of our Octopus Deploy servers. Also forgot to mention our Octopus Deploy is on a Load Balanced system.
As I am trying to configure the polling tentacle on our Octopus Server, Ports 443 & 10943 are open.PollingTentacleErrorLog.txt (3.1 KB)
I am running the command on the command line and using port 443 for --server-comms-port.
And still no success in creating a polling tentacle.
I have attached the error log.

Kind Regards,
Micheál Power

Thanks for getting back to me.

Ok, it looks like there might have been some confusion here, regarding my response.

You’re fine to leave the tentacle communications on the default port 10943. When creating a new tentacle, the network workflow goes like this:

  1. Contact the Octopus deploy API (either over HTTP or HTTPS, depending on what server URL you give it) and register the tentacle as a deployment target in Octopus. This only happens at creation time, and any firewall rules to allow HTTP/HTTPS can normally be removed after this step, if not longer required

  2. Regular polling communication happens on port 10943.

What looks like has happened here is that you’ve configured the tentacle communications port to be 443, and when it attempts to register the tentacle with the server via the API, it’s getting the HTML page that we present to connections on the tentacle communication port (for testing), instead of the JSON response from the API.

I hope this clarifies the situation and helps get things resolved for you!

Hi @Justin_Walsh,
The picture below will give you a better understanding of our setup.
The first image is our Octopus Deploy UI setup listening on port 443 and the second image we have mapped port 443 to 10943 so that is why we are trying to configure the polling tentacle using port 443.

I hope this makes it more clear in what I am trying to do.

Kind Regards,
Micheál Power

Hi Michael,

The polling tentacle needs to be able to reach port 10943 on the Octopus Server. Looking at your diagram this doesn’t look like it would currently be possible, instead, the tentacle would reach port 443 which will cause the error you’re encountering.

I think polling tentacles over websockets may be what you’re looking for. This will allow you to configure the Octopus Server to use port 443 for incoming polling tentacle connections rather than port 10943. It does require a little bit of additional configuration on both the server and tentacle. This is all detailed within the document I linked.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.