Unable to connect to new Tentacle

Hello. My company is just starting to evaluate Octopus deploy and from what I have read I am very hopeful of what it can offer us. We have the Octopus server installed and several Tentacles were installed by one of the vendors that we use. This seems to be working fine. I just installed the tentacle service on another server but a health check to this new machine fails with the error below reported in the server’s log file:

FATAL Timed out waiting for the machine to report its health.

This particular machine is reported as OFFLINE in this same log file. I am able to communicate to this tentacle from the Octo server using the sftp address as suggested in the help documentation. When I click the Reset button on the Connectivity tab of the machine from the Octopus portal I can see that the service on the actual tentacle is being restarted, so communication exists between the Octopus server and this particular tentacle.

Status on the Connectivity tab of the machine is as follows: Not started. This machine has recently been added or changed, and its communication channel is being reconfigured.

Both server and tentacle are running version

I’m not sure what to attempt next. I did create a release of my software and attempted to deploy to this machine, but it just kept clocking and never completed or threw any exceptions. After attempting to deploy the release, I did find that the nuget package was copied to the machine, so again, communications is occurring.

I have re installed the service on the tentacle several times and removed and readded it back to the server with no luck.

What am I missing? Any help will be greatly appreciated.


Hi Kevin,

Thanks for getting in touch. It sounds a little like the machine may be “duplicated” - i.e. created from a cloned VM image. Could that be the case? If so, let me know and we’ll work through fixing it.

If you have the appropriate access, setting up the Tentacle from scratch should get you up and running regardless:

  • If you have any important data on it, back up the Octopus Server and store the Master Key in a safe place
  • Uninstall Octopus Tentacle from the target machine
  • Rename the C:\Octopus folder on the target machine, e.g. to C:\Octopus-Backup
  • Delete the Machine from the Octopus Server’s Enviroments page

Then, reinstalling Tentacle on the target machine and using Add machine on the Octopus Server should get communication set up from scratch, side-stepping any configuration issues.

Let me know if this helps or if you need more info


Thanks for the response, Nicholas. I followed the steps exactly as listed below and I get the same result. When I first add the machine back to the environment and perform a Health Check, the new machine doesn’t show up in the health check response until I Reset the machine from the Connectivity tab (in which case I can see the service restart on the remote machine so communications is there) and run the health check again. At that point the other 4 machines report status back within seconds, but this new machine hangs for a bit and then finally it reports the “Timed out waiting for the machine to report its health” message.

I don’t know for sure, but it is very likely that this machine was duplicated as our desktop support uses that method I believe.


Hi Kevin,

Thanks for following up. It sounds like the connection to the machine is being established properly, but perhaps network issues are causing communication to fail later on? The Octopus versions before 2.4 can be particularly sensitive to this, and we’re currently testing some bigger improvements in a 2.5 release due in a week or so.

There are two things I think we can try. First, if you can send me the Tentacle.*.txt log files from the affected machine (nblumhardt at octopusdeploy.com) I can check for any obvious errors.

Second, if it’s possible, upgrading the Octopus server and all Tentacles to 2.5.4 when it is released shortly should steady things up.

Octopus is normally very reliable and robust, but network dropouts have caused us some issues so I’m suspicious that may be the cause here.

Ah - one third thing you might look at - a quick test: would you be able to time how long it takes to restart the Tentacle service on the machine? Some configuration issues resulting in very slow restarts can also creep in here.

Best regards,

Hi Kevin,

I’ve just examined the logs you sent - thanks! They look perfect, in that there’s no indication of network issues, slow restarts or other problems.

Would you be able to send a screenshot of the Machine’s Settings and Communications tabs in the Octopus Server, as well as the Tentacle Manager screen from the Tentacle?

Unless these show up some clues I think walking through reconfiguring the machine via Skype may be our best bet.

Also - we’ve now released Octopus 2.5 (http://octopusdeploy.com/downloads), which builds on the added features in 2.4 (http://octopusdeploy.com/downloads/2.4.10) to make quite a difference from the version you’re running.

Upgrading is via the Server only (install the new version there and the Tentacles can be upgraded automatically from the Environments page) so may be something to try if you have the opportunity.

Best Regards,

Was this issue ever with the solution here? We are having the same issue as described above, with the same version. We have the tentacles deployed to many servers, and one fails. It was either created from a clone or template in VMware. I followed the instructions in Post 2, but to no avail. I am wondering if upgrading to 2.5 will solve the issue.

Thank you, in advance.

@jfernsler no - I don’t think there’s been any more activity on this recently. Would it suit you to walk through fixing this via Skype? I’m “nblumhardt”, working in Australian Eastern Standard Time - feel free to just ping me, or let me know a time that would suit to book in.

Thanks for getting in touch!


Hello, I just wanted to add to this, since it appears it hasn’t been officially resolved yet. I ran into this issue today when trying to install a tentacle on a server for one of our projects and its UAT site. The machine had been created by cloning a VM a long time ago, and was recently decommissioned from production use, and renamed for the purpose of our testing environment. It had never had anything Octopus related installed on it previously. I tried uninstalling and reinstalling multiple times based on the instructions above, and debugging using the information located on the http://docs.octopusdeploy.com/display/OD/Troubleshoot+Listening+Tentacles docs page. Finally, after an hour or two of struggling with it, I decided to restart the Octopus Server service. Once the service came back up, the handshake immediately worked, and the server and tentacle were able to communicate.

I’m not sure if this will help anybody else, but that was the only thing that worked for me.

I do not know if this will help, be we ended updating everything to the latest version of Octopus and it resolved our issue.