Trying out 3.0, but license is for 2.0

I want to try out Octopus Deploy 3.0 and downloaded the pre release version.
Because we need the AzureCloud Service support, I am interested to find out if Octopus Deploy will be a fit.
When I open the management portal I see that I use version 2.6xxxx, can this be because the license I got, is for 2.0?
I can see this in the license xml.

I also think that this is not version 3, because I can not choose targets under the Environments tab.

Please tell me if I am doing something wrong, or what I can do to try out version 3.

Thanks in advance!

Hi Henry,

Thanks for getting in touch! You can use your 2.0 license for 3.0. Here is a blog post I just wrote explaining about licenses and what you need to qualify for 3.0:

It does sound like you have not run the 3.0 installer (did you see balloons?) or have to define an SQL server? Our community forum has the best details on installing the 3.0 pre-release and has links to the new installer: http://community.octopusdeploy.com/

Hope that helps!
Vanessa