TLS 1.2 with Octopus and Azure Storage Account


I have a Azure Storage Account which has recently been configured to TLS 1.2.

Now in Octopus, an inline script fails at row: $existingBackupBlobs = Get-AzureStorageBlob -Container $AzureBackupStorageContainerName -Context $backupStorageContext.

The error message is:
CloseError: The remote server returned an error: (400) Bad Request. HTTP Status Code: 400 - HTTP Error Message: The TLS version of the connection is not permitted on this storage account.

Does anyone know where in Octopus I configure it to run TLS 1.2 so that Octopus and the Azure Storage Account both can communicate with TLS 1.2?

Kindest regards

// Hannes

Hi @hannes.carleson

Thanks for getting in touch! Sorry to hear that you’ve run into an issue here.

It sounds like you’d need to ensure the server running Octopus has TLS 1.2 enabled, rather than Octopus itself. You could use a tool like IISCrypto to check how your server is configured. We have some documentation on TLS here that may help point you in the right direction.

Please let me know how you get on!


Hi and thanks for the answer.

The server that is running Octopus is Windows server 2012 R2. On that server I have downloaded IIS Crypto and when opening it all checkboxes are checked but grey. It says they are grey when there is no previous setting before, in other words the server setting. So a grey checkbox is a checked checkbox or no value at all?


It looks like grey checkboxes are to be expected on a first run and the OS defaults are used. You can read about that here - Why are all of the check boxes grey when I run IIS Crypto? - Nartac Software

@hannes.carleson, it looks like you are using PowerShell? You could try adding this to the top of your script to force TLS1.2.

[Net.ServicePointManager]::SecurityProtocol = [Net.SecurityProtocolType]::Tls12

This solved the problem, thanks!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.