There was a problem processing your request: 411 Length required

Whenever I edit any thing in octopus portal. Either try to delete a project or try to delete group orr try to delete machine from environment get the same error and operation is not performed.
Please see attached screens for detail



Hi Sam,

Can you show me the error you get when trying to delete a project? Also, could you check the Windows event log on the Octopus server to see if any additional details are logged?


Error 411 length required. I have attached above all the screens I get after clicking on buttons. Please check

Still got no answer. Please guide

Hi Sam,

Sorry for the delayed response, there’s not enough information to diagnose this problem and it seems to be specific to your installation. Can you answer the following questions which will help to narrow down the causes?

  1. Do you have a proxy server between your web browser and the Octopus server?
  2. If you remote desktop onto the server which Octopus is installed on, and use a web browser from that server, do you get the same error?
  3. Do you get the same error when using other web browsers?
  4. What version of Windows Server is your Octopus server running on?
  5. Is Octopus running behind a reverse proxy/load balancer? Is it sharing a port with another service such as TeamCity?


Yes, you were right. Proxy server was causing this issue. many thanks for your guidance.