The remote server returned an error : (409) Conflict

I am new to Bamboo server and Octopus deploy - I had a build plan fail in bamboo server because of a script error on the job task. I am trying to get the build to re run, however I keep getting

18-May-2017 05:44:14 (OctoPack target) ->
18-May-2017 05:44:14 EXEC : The remote server returned an error : (409) Conflict… [C:\Bamboo\bamboo-home\xml-data\build-dir\CMW-SBP468-JOB1\src.legacy\SSQV4\SSQV4.csproj]
18-May-2017 05:44:14 C:\Bamboo\bamboo-home\xml-data\build-dir\CMW-SBP468-JOB1\src.legacy\packages\OctoPack.3.0.65\tools\OctoPack.targets(108,5): error MSB3073: The command "“C:\Bamboo\bamboo-home\xml-data\build-dir\CMW-SBP468-JOB1\src.legacy\packages\OctoPack.3.0.65\tools\NuGet.exe” push “C:\Bamboo\bamboo-home\xml-data\build-dir\CMW-SBP468-JOB1\src.legacy\SSQV4\obj\octopacked\SSQV4.1.0.1-PMD-273-ICA-feed-a.nupkg” ******** -s " exited with code 1. [C:\Bamboo\bamboo-home\xml-data\build-dir\CMW-SBP468-JOB1\src.legacy\SSQV4\SSQV4.csproj]

I removed the files from the deploy directory but this did not fix the issue. I suspect there is an entry in the database that I can not see in the web application. How can I get the information in octopus deploy removed?

I am using octopus deploy version 3.12.8.

Hi Anthony,

Thanks for reaching out! The issue is actually happening when your Bamboo build is trying to push the nuget package to the Octopus Server, so I don’t think any entry on a database might be causing this.

From that log I can see you are using a fairly old version of Octopack (3.0.65) and a fairly recent version of the Octopus Server (3.12.8). As a first step I recommend you to upgrade to the latest Octopack version, commit those changes to source control and trigger another build.

If that doesn’t work, please send me the full Bamboo build log. Feel free to set this conversation as Private so the contents of it stay between you and our staff.


Thanks for the reply, build does create the nuget packages. I found them from the build prior. I was adding in a new project to build, however, the nuget version is not changed so when I tried to re run the build, the packages already existed on the deployment server.

I tried removing them, but that did not help.

We have other projects building fine with that version of octo pack.

I disabled the new script and still gt the same error. I created a new branch to see if it would build (with the new script disabled) and all went fine. I tried to re run the build in bamboo (still disabled the new script) I got the failure above.

It appears that once one of the applications are built and sent to octopus, there is no re running that is possible. I continue to get errors from the copy on a re run of a build plan

Its possible that you are getting this error then because of the duplicate package. If you want to overwrite a package with another with the same ID+Version combination, you should add ?replace=true at the end of your push URL as explained in our docs

In your case that’ll be

Let me know if that works

Thank you for sending me to that section of the documentation. I finally found where I needed to place this in bamboo and now I am getting a successful re runs of a build.

Thanks again

Glad to hear that!