The package version 'xxx' for 'yyy' returned from the package repository doesn't match the requested package version 'xxx'

integration

(g.bunce) #1

Using octopus 3.11.3 with VSTS external package feed.

All working fine until the VSTS V2 package feed started reporting unauthorized errors. Nothing appears to fix this (possibly disabled by VSTS).

Update Octopus to point to V3 of the VSTS package feed. Save and Test = all works fine.

Run deployment script, instant failure with message “The package version ‘xxx’ for ‘yyy’ returned from the package repository doesn’t match the requested package version ‘xxx’”. Package versions are the same in the message.


(Dalmiro Grañas) #2

Hi,

Thanks for reaching out! Could you adding a new external feed in Octopus for your already existing VSTS feed and make your package use that one instead?

If you keep having this error, please send us:

You can securely upload your files to this link that only our staff has access to

Best regards,
Dalmiro


(g.bunce) #3

In the end I re-created the packages and they were loaded in Octopus fine