The package version '1.0.0.21+2f052aba' for 'xxx' returned from the package repository doesn't match the requested package version '1.0.0.21'

Does Octopus support semver 2.0 versions with metadata? I’ve tried to create a package with the git sha in the version metadata, but I’m getting the error:

The package version ‘1.0.0.21+2f052aba’ for ‘xxx’ returned from the package repository doesn’t match the requested package version ‘1.0.0.21’

The package is downloaded from an external (github) nuget feed.

Hi Peter,

Thanks for getting in touch!

I’ve run a quick test on this and it does seem to work.

It may be that I’ve configured something differently during my test, so, this is how I had it setup:

External Feed:

Package Step:

Release:

I’m assuming that you’re running this on a Cloud instance, my instance is currently running Build 8275. If you want to check yours I can re-test if they’re on different builds.

Also, the calverp/grades repository I used in my test is public if you want to try testing with that too and see if you get a different result.

Regards,
Paul

Hi Paul, one difference that I’ve noticed is that I’m not using the “GitHub Repository Feed” feed type, instead a generic “NuGet Feed” (Working with the NuGet registry - GitHub Docs).

I’m using a cloud instance, build 9562.

Thnx,
Peter

Yeah, that would explain the difference.

I believe I have replicated the behaviour that you’re seeing, are you able to confirm that when you’re creating a release you see just the package version displayed without the metadata?
e.g.
image

I did find an old issue (Package with metadata cannot be downloaded · Issue #3434 · OctopusDeploy/Issues · GitHub) that sounds similar. The workaround of configuring the step to download the package directly on the target instead of the server also works.
e.g.

I’m going to raise this with our engineers to see if they’re able to shed any additional light on this.

Yes, when selecting the package I see the version without the metadata.
Will try the workaround, thanks!

1 Like

I’m deploying the application to azure using a “DEPLOY AN AZURE APP SERVICE” step. Looks like this step is missing the option to change the download behavior.

Ah, that option will only appear for steps that make use of a Tentacle agent, unfortunately.

In that case, the only workaround would be to avoid using metadata within the package version until we have a fix in place.

I’ve raised an issue that you can track here: Unable to download a package with metadata from a GitHub NuGet feed · Issue #7303 · OctopusDeploy/Issues · GitHub

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.