The HTML document does not contain Web service discovery

usability
(Singh Dharmbir) #1

Hi Team,
While doing the deployment I getting below, help me to fix this issue

Installing Sitecore update package 'D:\inetpub\wwwroot\xxxx\App_Data\TDS_Update_Packages\xxx.TDS.Layouts.update' on 'https://abc.com'

August 22nd 2019 00:33:35

Error

New-WebServiceProxy : The HTML document does not contain Web service discovery

August 22nd 2019 00:33:35

Error

information.

August 22nd 2019 00:33:35

Error

At C:\windows\system32\WindowsPowerShell\v1.0\Modules\SPE\Invoke-RemoteScript.p

August 22nd 2019 00:33:35

Error

s1:250 char:43

August 22nd 2019 00:33:35

Error

+ ... $singleConnection.Proxy = New-WebServiceProxy @proxyProps

August 22nd 2019 00:33:35

Error

+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

August 22nd 2019 00:33:35

Error

+ CategoryInfo : InvalidOperation: (https://mycloud...ation.asmx?

August 22nd 2019 00:33:35

Error

wsdl:Uri) [New-WebServiceProxy], InvalidOperationException

August 22nd 2019 00:33:35

Error

+ FullyQualifiedErrorId : InvalidOperationException,Microsoft.PowerShell.C

August 22nd 2019 00:33:35

Error

ommands.NewWebServiceProxy

August 22nd 2019 00:33:35

Error

August 22nd 2019 00:33:35

Error

The remote script failed with exit code 1

August 22nd 2019 00:34:03

Info

Guidance received: Retry

August 22nd 2019 00:34:03

Info

Retry attempt #1 of 10

August 22nd 2019 00:34:07

Info

Installing Sitecore update package 'D:\inetpub\wwwroot\xxx\App_Data\TDS_Update_Packages\ICP.TDS.Layouts.update' on 'https://abc.com'

August 22nd 2019 00:34:08

Error

New-WebServiceProxy : The HTML document does not contain Web service discovery

August 22nd 2019 00:34:08

Error

information.

August 22nd 2019 00:34:08

Error

At C:\windows\system32\WindowsPowerShell\v1.0\Modules\SPE\Invoke-RemoteScript.p

August 22nd 2019 00:34:08

Error

s1:250 char:43

August 22nd 2019 00:34:08

Error

+ ... $singleConnection.Proxy = New-WebServiceProxy @proxyProps

August 22nd 2019 00:34:08

Error

+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

August 22nd 2019 00:34:08

Error

+ CategoryInfo : InvalidOperation: (https://mycloud...ation.asmx?

August 22nd 2019 00:34:08

Error

wsdl:Uri) [New-WebServiceProxy], InvalidOperationException

August 22nd 2019 00:34:08

Error

+ FullyQualifiedErrorId : InvalidOperationException,Microsoft.PowerShell.C

August 22nd 2019 00:34:08

Error

ommands.NewWebServiceProxy

August 22nd 2019 00:34:08

Error

August 22nd 2019 00:34:08

Error

The remote script failed with exit code 1
(Daniel Fischer) #3

Hi @singh.dharmbir,

Thanks for getting in touch! This issue does not seem to relate to Octopus. I can point you to an online result that I found for this error, but I’m not able to provide much more help past this.

If you only saw this error in Octopus and your script worked fine outside of Octopus, I would be happy to further investigate why Octopus might be breaking the script.

Let me know if you have any further questions here.

Best regards,
Daniel