TFS "Deploy Octopus Release" gets a timeout even if timeout setting is not reached

(Øivind Solberg) #1

Hi
We have a “Deploy Octopus Release” step in a TFS build definition. This step fails with a timeout after 10 mins - the actual Octopus deployment successfully completes after about 11 mins.
I have tried to set the Timeout setting in the TFS step to 30 min, but it still fails after 10 min.
Anyone have an idea why this happens, or why the 30 min timeout setting does not apply?
Not sure if this is a TFS or Octopus specific problem…


Thanks.

(Matthew Casperson) #2

Hi @oivind.solberg, thanks for reaching out.

That may be a bug in the TFS extension (we’ll take a look and try to replicate it), but you can try adding the timeout command line argument manually in the Additional Octo.exe Arguments field. The docs at https://octopus.com/docs/api-and-integration/octo.exe-command-line/deploy-release list the options that are available, and --timeout is the option you can set to increase the timeout from the default of 10 minutes.

The screenshot below shows the Additional Octo.exe Arguments field under Advanced Options.

Regards
Matt C

(Matthew Casperson) #3

Hi @oivind.solberg,

Looking at this further, the timeout defined in that step is the time TFS will spend waiting for the step to continue. This value is independent of the time the Octopus client will wait for the Octopus deployment to finish.

Passing the --timeout value is the correct way to resolve the issue. An issue has been created about this disconnect between the TFS and the Octopus timeout at https://github.com/OctopusDeploy/OctoTFS/issues/134.

Regards
Matt C

(Øivind Solberg) #4

Understand, we’ll use the --timeout setting for now.
Thanks!

(system) closed #5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.