Tentacle crash on one of several machines


On one of our webservers the tentacle mysteriously doesn’t work. The service starts and seems to be running but we can’t access the health check and looking in the windows error logs we get this:

2012-02-29 07:06:58,619 [5] ERROR Octopus [(null)] - System.Threading.ThreadAbortException: Thread was being aborted.
at System.Threading.Thread.SleepInternal(Int32 millisecondsTimeout)
at Octopus.Shared.Time.Sleep.For(Int32 milliseconds) in c:\BuildAgent\work\7bf5272a44079f5\source\Octopus.Shared\Time\Sleep.cs:line 10
at Octopus.Tentacle.SuctionCup.TentacleGuardian.Start() in c:\BuildAgent\work\7bf5272a44079f5\source\Octopus.Tentacle\SuctionCup\TentacleGuardian.cs:line 45
at Octopus.Shared.Startup.WindowsServiceHost.RunService() in c:\BuildAgent\work\7bf5272a44079f5\source\Octopus.Shared\Startup\WindowsServiceHost.cs:line 40

Any ideas on what this could be?

Hi Andreas,

Can you try stopping the service, and then using a command prompt to run the Tentacle manually? You’ll have to call it like this:

Tentacle.exe /agent

You should find it under the C:\Octopus\Tentacle\Agent folder, and you may need to run it as an Administrator.


I’m having the same error:

The error above is thrown when the service is shut down, so I’m not sure if it is relevant or not…
Regardless, I have 4 machines that are not “healthy” and 2 that are fine (I installed 6 tentacles today) The machines are basically clones of each other and I haven’t figured out what the difference is at this point.

I uninstalled, deleted c:\octopus, and reinstalled and I get the same issue. The service looks like it is running and I get the default web services boilerplate if I hit the tentacle service with a browser, so it looks like things are running. It just doesn’t like something…


I was able to run tentacle.exe /agent I get the following:

  • Tentacle

IHealthService listening on: http://localhost:10933/
IJobService listening on: http://localhost:10933/Jobs/
IPackageService listening on: http://localhost:10933/Packages/
Running. Press to shut down…

If I run the Health Check from the server, it does not see this machine as healthy:

Message from the server including the stack trace is attached.

octopusstacktrace.txt (9 KB)

Hi Lynn,

Is it possible that Windows Firewall or some other network issue is preventing the machines from connecting? If you RDP to the Octopus Server machine, can you then browse to the web service URL on the tentacle?


Thank you for forcing me to think about it the right way. I did have a network issue.

Sorry to bother you with that one.