Tentacle Allow service to interact with desktop

I have a Powershell script that does some IE automation and it doesn’t completely work when deployed to the tentacle. I’m thinking I need to modify the local system account that the Tentacle service is logging in with to Allow it to interact with the desktop.

The issue is that when I try to restart the tentacle through the manager it fails to start claiming that the service didn’t respond in a timely manner, but this happens almost instantly so I don’t see how it could have timed out.


Thanks for reaching out. It is a known problem that you cannot automate tasks with Powershell + IE from a non-interactive session. Octopus executes everything through the Tentacle service, so there’s a high change that you’re not gonna be able to do this, even if you allow the account to interact with the desktop.

Could you share the steps you followed to change the account so i can try to reproduce it myself? Also please send us the latest logs of your tentacle. You can find them at [Tentacle Home]\Logs. You can see the path of [Tentacle Home] from the Tentacle Manager.



Steps to reproduce:

  1. Open Services.msc
  2. Find OctopusDeploy Tentacle
  3. Right click > properties > Log On tab
  4. Check “Allow service to interact with desktop”
  5. Press OK
  6. Open Tentacle Manager
  7. Restart Tentacle

Here’s the log

2015-06-19 11:26:46.8680 INFO Stopping service…
2015-06-19 11:26:48.0050 INFO Waiting for service to stop. Current status: StopPending
2015-06-19 11:26:49.0050 INFO Waiting for service to stop. Current status: Stopped
2015-06-19 11:26:50.0050 INFO Service stopped
2015-06-19 11:26:50.9010 FATAL System.InvalidOperationException: Cannot start service OctopusDeploy Tentacle on computer ‘.’. —> System.ComponentModel.Win32Exception: The service did not respond to the start or control request in a timely fashion
— End of inner exception stack trace —
at System.ServiceProcess.ServiceController.Start(String[] args)
at Octopus.Shared.Startup.ServiceCommand.Start() in y:\work\refs\heads\release-2.4\source\Octopus.Shared\Startup\ServiceCommand.cs:line 188
at Octopus.Shared.Startup.ConsoleHost.Run(Action`1 start, Action shutdown) in y:\work\refs\heads\release-2.4\source\Octopus.Shared\Startup\ConsoleHost.cs:line 36

Hi Nick,

That setting should not break your Tentacle service. That said, I’ve tested it myself on my end (it didnt break my Tentacle service) and it still doesn’t allow Powershell to interact with IE, as I expected.

Also, even Microsoft doesnt recommend to have that setting enabled https://technet.microsoft.com/en-us/library/cc782435(v=ws.10).aspx (search for the keyword “interactive”). Apparently is a setting that’s there for legacy support.

Sorry for the crappy news,