Tentacle 3.0 Framework Dependency


I am trying to upgrade from Octopus 2.6 to 3.1. I have 4 machines in my network that are still running Windows Server 2003. I noticed (eventually) in the docs at http://docs.octopusdeploy.com/display/OD/Installing+Tentacles this line…

Windows Server 2003 SP2 (N.B. Not supported for Tentacle 3.1 and up due to .NET 4.5 dependency)

I notice that this specifically references Tentacle 3.1. Will Octopus Tentacle 3.0 run on Windows Server 2003? Would it be possible to temporarily run Octopus Server 3.1 with Tentacle (or similar) until we get these machines upgraded?


Thanks for the questions.
Octopus Tentacle 3.0 will run on Windows Server 2003 and is compatible with Octopus Server 3.1 so you shouldn’t have any problems running 3.0 Tentacle on those machines until you can get the upgraded.


Thanks, Shane!

Can we still use the 3.0 tentacle with the latest version of octopus deploy? We still have a number of servers that are windows 2003 that have yet to be phased out and that we still need to support. We have just upgraded our octopus server hardware so went with the latest version but just found that we can’t use the latest tentacle on our 2003 servers so are wondering which version of the tentacle we should install on those servers.


Hi Chris,

You can still use 3.0 Tentacles with 3.2 Server.


Thanks that is working for us