SSRS Reports Deployment Issue


(jian huang) #1

Hi Octopus team,

I have a octopus project to deploy SSRS reports, below is my deployment steps.

When I run this deployment, about 4 out of 10 times, I get following errors half way through the report files
‘The request failed with HTTP status 503: Server Too Busy’

However, If I just run step 4 for the deployment, the all the deployments are succeed.

I am guessing the previous steps consumed too much memory? I checked the server memory usage, it is about 40-50% at all time, not sure what caused the failure.

Thanks


(Shane Gill) #2

Hi,

Thanks for getting in touch.

Do the first three steps do anything with SSRS? Would restarting the SSRS service between step 3 and 4 help?

Unfortunately there isn’t a lot of information around about that particular SSRS error. When that error happens are you able to redeploy successfully? Maybe some error handling with retries in your “Create New Reports” step would lead to more reliable deployments?

Cheers,
Shane


(jian huang) #3

The first 3 steps have nothing to do with SSRS, just deploying the NuGet package, delete a file and get the release number.

When that error happens, the project deployed successfully, but will be missing reports (we have over 100 reports, when that error happens, all the reports after the error wont be deployed).

Doing the retry approach still not solving the root cause, and it might still fail in some cases.


(Shane Gill) #4

What do you think the root cause is? To me it looks like something to do with SSRS. It is difficult to diagnose with a vague error message coming from SSRS, especially being Octopus experts and not SSRS experts.

I can offer suggestions to workaround the issue using Octopus but without knowing the cause of the SSRS issue I’m afraid I can’t offer much more help.


(jian huang) #5

Hi Shane,

Yea, agreed, at this point it is difficult to identify the root cause, I will continue to investigate, thanks for the help.