SSIS post deployment Environment variable checkbox empty

Hi

I have an issue whereby when I parameterize the SSIS connectors with say a servername property, post deployment this does not get picked up as expected, and the package fails.

After deploying the SSIS ispac file via Octopus and selecting to map across the parameters to the environment variables, I noticed that when executing the SSIS package on the SQL server from within the catalog, it seems to forget that there is a default variable. Therefore you have to manually click on the Environment checkbox, for it map the variable across, thus preventing continuous deployment.

Is there a fix for this?
Thanks

Hi @bhatti_134,

Welcome to the Octopus forums!

Thanks for reaching out.

Which version of Octopus Server are you currently running? Would you be able to provide more detail on the step you’re running with some screenshots of the setup? Could you also attach the tasklog with the full error? If anything needs to be private, feel free to privately message the above.

Please let me know if you have any questions.

Thanks,
Jeremy