Skipping Unavailable or Unhealthy deployment targets not working for runbook execution

Hi -

I have a maintenance script I want to execute in a runbook. In the ‘Deployment Settings’ section of the project I’ve configured deployments to skip unavailable and unhealthy targets. When I execute the runbook, however, the job fails because Octopus tries to connect to the unavailable target.

Does the project-level ‘skip unavailable and unhealthy target’ settings apply to runbook executions as well?

Thanks,

Hi @snaulls,

Thank you for contacting Octopus Support.

I’d like to reproduce this in a test environment. Could you confirm what version of Octopus Server you are currently running?

Let me know at your earliest convenience.

Regards,
Donny

Thanks for the quick response. We’re running 2020.1.22

Hi @snaulls,

Thank you for getting back to me.

I’ll dig in and get back to you once I’ve done a bit of testing.

I appreciate your patience while I look into this.

Regards,
Donny

Hi @snaulls,

Thanks for your patience! We gave this a test, and I think I see what might be happening. The settings you configured under the Deployments > Settings tab to skip unavailable and unhealthy targets is just deployment process-specific, and isn’t project-wide so setting it here won’t impact runbooks. This setting would also need to be configured on the runbook itself, which is under its Settings tab like shown below.

I hope that helps, and please let us know how you go!

Best regards,

Kenny

Found it and executed a test run. Results were as expected; unhealthy servers were skipped. Thanks!

1 Like