Skipping this step as no machines were found in the roles

I run in the following problem and I cant figure out what im doing wrong.

I create a project with the following steps.

  1. Powershell creates a vm in azure that also includes the octopus tentacle
  2. I put a pause in for 300 seconds
  3. Then I use a powershell script to run on the new azure vm localy that change the drive letter.
    Here I see the error message : = Success: Step 8: Mount Disk to E ==
    08:09:59 Info | Skipping this step as no machines were found in the roles: testdb, Database, Timer Service, web, iis


But when I look in my environments I see that the machine is there and alive.
Calamari is also update by policy and health check before it reach step 3. That’s why I put in the pause …

The weird thing is when I run the job again. With out creating the vm that step 1 I disable.
It runs successively. But I want to do everything in 1 project.

Can u assist please.

Hi Nico,

Thanks for getting in touch! I think the issue here would most likely be related to how releases work in Octopus. When your release is created we take a snapshot which includes the state of your targets. Your deployment will need to have its own health check in order to see the target as healthy. While Octopus may see this target as healthy outside of the deployment, the release does not know this, so it must manually be run as a part of the deployment.

You should be able to add a Health Check step before step 3 to remedy this problem. :slight_smile:

If the above does not help you out here, can you please attach a full deployment log.

Best regards,