Silent failure of copy files stage during deployment


I have a deploy process which uses a ‘Deploy NuGet package’ step. This step fails to copy files from the octopus working directory to the custom installation directory specified in the step settings. It does not throw an error. The task log reports that the ‘Copy files to …’ stage of the deployment was successful, but when I examine the directory, it is empty. This same step in the same deployment works perfectly on different environments and I have checked that there are no environment-specific variables and nothing different in the configuration of the machine. It is only a problem when deploying to one particular machine, but since there is no error I have no way to determine the cause. Other deployments for other projects also have the same problem when deploying to this machine. I have checked NTFS permissions. Can anyone help?

Hi Dave,

Thanks for reaching out. Can you confirm if this is happening only on this machine and for all projects/environments deploying to it?

Also could you send us a deployment log, and the full path where you expected to see files after the deployment?



Hi, yes I can confirm it’s just this machine. Attached is the log. Should deploy to C:\Apps\NetS\SE\1.0.96 but it’s empty.

ServerTasks-23839.log.txt (17 KB)

Hi Dave,

Sorry i’m dumb and i forgot to ask you to turn on the debugging variables before sending the log. Could you do so, then create a new release and send me back the raw log?


  • I see that you have a 3rd step called “Cleanup old versions”. Could you attach a screenshot of how the configuration of that step looks like?

  • What is the name of the machine where the files are missing?