Sign in with your Microsoft Windows domain account


I’m changed my Octopus authentication mode to ActiveDirectory and setup my AD accounts in Octopus Users and Roles. I’m able to login by using my AD username and password, but clicking on the “Sign in with your Microsoft Windows domain account” does not log me in. I see the “Checking credentials. Please Wait…” page and then I’m redirected back to the sign in page. I don’t see anything in the Event Log nor in OctopusServer.txt logs. What could be wrong?


Hi Dawid,

Thanks for getting in touch. Is your Octopus server configured to run as Local System (the default), or does it run as a custom user account?

To be honest there are plenty of things that could stop this from working. From memory we use an NTLM challenge when you click that link. The problems could range from NTLM being disabled in your domain via group policy, to firewall issues, etc.

Is your team in touch with Ian Paullin? He set up an Octopus server for Avanade/Accenture and might be familiar with making it work with your domain setup.


Hi Dawid (and Paul) :slight_smile:

I haven’t run into that exact issue before. For us, it’s worked since day one, but we’ve always used AD for users/groups - we’ve never switched. That said, if you haven’t done this already - it’s best to setup the Octopus Server Service using an domain account; preferably a “service” account exclusive just to services. That should enable NTLM authentication for Octopus.

You could (temporarily) substitute your own AD account to see if it works. If it does, then go about provisioning a specific service account just for Octopus and swap the credentials once the service account has been created.


Hi, I faced with the same problem. After switching to use AD, I can log in only using login form. Link “Sign in with your Microsoft Windows domain account” return 303, but me and dashboard endpoint return 401. I have already tried to run Octopus Server Service as domain user - result nothing. What I can do? Is total Octopus server reinstall the only solution?