SFTP Error


We are receiving the following error when trying to SFTP to an amazon server (not under our control). The correct firewall rules are in place and I can SFTP from FileZilla on the Octopus Server machine.

Error    11:25:52
Unable to connect: An I/O exception occurred.
Fatal    11:25:52
An I/O exception occurred.
EnterpriseDT.Net.Ftp.ControlChannelIOException: An I/O exception occurred.
   at EnterpriseDT.Net.Ftp.FTPControlSocket.LC5b1tiqSvd()
   at EnterpriseDT.Net.Ftp.FTPControlSocket.lq1PqiuWmSk()
   at EnterpriseDT.Net.Ftp.FTPControlSocket.RAQb1J67FVc()
   at EnterpriseDT.Net.Ftp.FTPClient.AJMflaYCwG(FTPControlSocket )
   at EnterpriseDT.Net.Ftp.Ssl.SSLFTPClient.Connect()
   at EnterpriseDT.Net.Ftp.SecureFTPConnection.Connect()
   at Octopus.Tentacle.Integration.Ftp.FtpSynchronizer.SynchronizationSession.ConnectAndSynchronize() in y:\work\refs\heads\release-2.4\source\Octopus.Tentacle\Integration\Ftp\FtpSynchronizer.cs:line 99
   at Octopus.Tentacle.Integration.Ftp.FtpSynchronizer.SynchronizationSession.Execute() in y:\work\refs\heads\release-2.4\source\Octopus.Tentacle\Integration\Ftp\FtpSynchronizer.cs:line 89
   at Octopus.Tentacle.Integration.Ftp.FtpSynchronizer.Synchronize(FtpSynchronizationSettings settings) in y:\work\refs\heads\release-2.4\source\Octopus.Tentacle\Integration\Ftp\FtpSynchronizer.cs:line 16
   at Octopus.Tentacle.Procedures.Implementations.Ftp.FtpUploadProcedure.Upload(ProcedureState state, CancellationToken cancel) in y:\work\refs\heads\release-2.4\source\Octopus.Tentacle\Procedures\Implementations\Ftp\FtpUploadProcedure.cs:line 69
   at Pipefish.Async.CaptiveThread`1.ThreadAction(Action`2 action, Guid operationId, IActivitySpace space, Guid captiveThreadId) in y:\work\3cbe05672d69a231\source\Pipefish\Async\CaptiveThread.cs:line 114

Any ideas?



Hi Adrian,

Thanks for getting in touch! In the FTP step configuration settings could you try using passive if you are using active or vice-versa.

Let me know how that goes.

Hi Vanessa,

I have tried both passive & active but has the same error.



Hi Adrian,

Thanks for trying that. I think we have figured out the issue here, Octopus can only do two types of FTP.
Regular FTP and FTPS but not SFTP (there is a difference).
I do not know if there is anything we can do to help in this case, sorry.
I am assuming based on what you said this SFTP is strictly all you have access to on this particular instance?


I’m having the same issues with Amazon and trying to deploy to SFTP.

I can connect just fine from the same machine OctopusDeploy is installed using Filezilla etc.

I’ve tried Passive, and active as well as selecting FTP / SFTP options to no success.

Hi Jason,

Thanks for getting in touch! Octopus does not currently support SFTP, only FTP and FTPS.


Vanessa is SFTP support on anyone’s backlog there? My organization is in the same situation as the OP, we are FTP’ing to an external CDN that uses SFTP.

Hi David,

SFTP support is not currently on our backlog. We use Uservoice for users to request features that they’d like to see on Octopus. If it gets enough votes we’ll implement it.

Think you can log a request on Uservoice with a brief business case on why do you need SFTP support?