Services not restarting after reboot

Last night our servers did Windows Update and rebooted. The Octopus service and several tentacles did not restart, even though they are set to “Automatic.”

I have seen this in other applications, and my recommendation is that Octopus and Tentacle services install as “Automatic (Delayed)” instead of just “Automatic.”

Hi Jack,

Thanks for letting us know, I’ll see what we can do in the next release.


I second this - noticed a failed start before aswell and solved by using Automatic (Delayed)

Yep, this has been an issue for quite a while and was something which I have noted in the past.

My work around for the time being was to create a GPO to attempt to restart the service across our domains.

Automatic (Delayed) will work as well.

You can also use sc.exe manually after service install and set a Dependency for the Octopus services to depend on Workstation (LanmanWorkstation) which pretty much ensures you the server is ready. Maybe Paul can add this to his installers as a default.

I do this, via code, for our in-house Windows Services and it really helped and prevented my services from starting too soon and failing.

I think it’s a little more bullet-proof than running them as Delayed. Just my opinion.


This happened to us today. Following our regular patching none of the servers that were restarted were able to start their tentacles. Going in and manually starting them worked instantly. Manually rebooting a single server was no problem. It’s only when we restarted a number of servers at the same time did it fail.

I can’t test if the ‘Delayed’ option helps or not until next month when the patches go out. Running