Service not starting after upgrade

Hi, We are unable to start the Octopus Tentacle Service after upgrading to on a Windows 2003 server. It does have .Net4 installed. Log is below.

The description for Event ID ( 0 ) in Source ( Octopus ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: 2013-06-20 12:40:04,360 [1] ERROR Octopus [(null)] - System.InvalidOperationException: Cannot start service Octopus Tentacle on computer ‘.’. —> System.ComponentModel.Win32Exception: The service did not respond to the start or control request in a timely fashion
— End of inner exception stack trace —
at System.ServiceProcess.ServiceController.Start(String[] args)
at System.ServiceProcess.ServiceController.Start()
at Octopus.Shared.Startup.ServiceInstaller.StartService(String name) in c:\w\e6923628be6eaf72\source\Octopus.Shared\Startup\ServiceInstaller.cs:line 562
at Octopus.Shared.Startup.ServiceInstaller.InstallAndStart(ServiceOptions options) in c:\w\e6923628be6eaf72\source\Octopus.Shared\Startup\ServiceInstaller.cs:line 83
at Octopus.Shared.Startup.ServiceInstaller.<>c__DisplayClass1.b__0() in c:\w\e6923628be6eaf72\source\Octopus.Shared\Startup\ServiceInstaller.cs:line 31
at Octopus.Shared.Startup.ServiceInstaller.AdminRequired(Action actionThatMayRequireAdminPrivileges) in c:\w\e6923628be6eaf72\source\Octopus.Shared\Startup\ServiceInstaller.cs:line 123
at Octopus.Shared.Startup.ServiceInstaller.Install(ServiceOptions options) in c:\w\e6923628be6eaf72\source\Octopus.Shared\Startup\ServiceInstaller.cs:line 31
at Octopus.Tentacle.Commands.InstallCommand.Execute() in c:\w\e6923628be6eaf72\source\Octopus.Tentacle\Commands\InstallCommand.cs:line 36
at Octopus.Shared.Startup.CommandProcessor.Process(String[] args) in c:\w\e6923628be6eaf72\source\Octopus.Shared\Startup\CommandProcessor.cs:line 40


Does this happen after a reboot or even when starting it manually?

Are you able to run Tentacle.exe manually (not as a service, but by double-clicking the executable in Windows Explorer) or does that also fail?

My guess is that it may be related to this issue:


Hi Paul,

The service does not start at all. I am able to run Tentacle.exe manually.

I have installed the update and the service still did not start. Even uninstalled the tentacle and installed it to a new location but still unable to start the service

We are having the exact problem, Was anyone able to solve this?

Same issue here with the server. OS is 2008 Standard SP2. It will start in interactive mode. I also tried installing on a duplicate machine with the same results??? I was able to install and get a backup running on a WIndows 7 Enterprise machine.


Solved -

Set the following to False (was true):


The service fired right up.


Perfect… Thank you

Thank you! This worked a treat.