Release notes

Hi all, i am new to Octopus … and TeamCity, and powershell … so please forgive my knowledge level.

I am trying to set a variable in Octopus to the release notes contained within the nupsec file (within the nuget package)

how do i do this

Hi Asif,

Thanks for getting in touch! If you add the release notes to the metadata of the NuGet package (in the NuSpec), then Octopus will read that into the release notes for the release the package is attached to.
What you should find, is that once the release is created with a package with this information, it should show in your UI on the release page. If you find it isn’t then I would think its one of two things.

  1. If you have ill formed tags in your release notes such as html we sanitize this very heavily and it may not show. To check if this is the case, click edit and the raw data will be shown in the release notes field.
  2. How are you adding the release notes to the NuSpec and when? Octopack has a way to add the release notes via a file: OctoPackReleaseNotesFile An example can be found in the documentation: http://docs.octopusdeploy.com/display/OD/Using+OctoPack

Let me know what you find.
Vanessa

Hi Vanessa and thanks for your reply. We are currently manually building a nuspec file via powershell in a build step prior to our MSBuild step. From what i can see the nuget package and nuspec file are correct. I have attached this.

On the release page i believe the release notes are coming through, however when i try to use the variable nothing comes through. In the attached ocotpus.gif file you can see me trying to retrieve the variable, Release notes doesnt come through, but release number does.

Please advise

DragonOil.Web__15_.nuspec (624 Bytes)

Hi Asif,

Sorry you are right. The release notes for the package show up under the package, but are not available in the release notes variable for the release.
How are you creating your releases? If you are using octo.exe then you can pass in some release notes. As you are using TeamCity - if you are using create-release you can use either --releaseNotes or --releaseNotesFile http://docs.octopusdeploy.com/display/OD/Creating+releases

Vanessa

Hi Vanessa. I am currently using CreateRelease within team city, see attached screenshot.

I am actually trying to pass the releasenotesfile like below, but nothing seems to come through. I did also try --releasenotes but that didnt seem to work either.

–releasenotesfile=%system.teamcity.build.changedFiles.file%

see http://help.octopusdeploy.com/discussions/questions/3716-octopack-release-notes-teamcity

Apologies but i am getting really confused as to whether or not this is even possible. Can you please let me know what exactly needs to be done. I feel this is going around in circles and i am not getting anywhere

Hi Asif,

The support ticket you have linked is for OctoPack, we are now talking about octo.exe.
I was able to use a file fine:
C:\Users\Administrator\Downloads\OctoEXE>octo.exe create-release --project "PHP Deployment to IIS" --server http://localhost/ --apiKey API-KEY --releasenotesfile ../create-release-notes.txt
Which resulted in the correct behavior see my screenshot.

So if you think it is still not working, could you provide the build log from TeamCity that creates the release to see if the file name and path are correct for the command.

Vanessa

Hi Vanessa,

I believe I have seen the same issue but I wanted to clarify something. I’m using octo.exe to pack passing the --releasenotesfile parameter. I can see in ProGet (the NuGet server that I’m using) that the release notes are correctly included in the package.

I do not see the release notes in the “Release Notes” text area on the create release page in Octopus, is this intentional?

I do however see the release notes once the package has been created, wondering if this is the source of confusion that Asif has seen?

Hi Tim,

Very possibly. There are two places for release notes. When they are added to a package, we show it at package level, as a release could have more than 1 package.
So package release notes do not end up in the release release notes field. We do have an enhancement scheduled to add a variable for the package release notes to allow them to be used in emails and other parts of the deployment process.

Vanessa

I ran into this exact situation (via msbuild /p parameters) as well; the release notes are at the package level, not the release level, so “Octopus.Release.Notes” is empty. I would appreciate this enhancement greatly.

Hi,

We do have a UserVoice suggestion for this exact feature: http://octopusdeploy.uservoice.com/forums/170787-general/suggestions/7639422-default-release-notes-for-release-created-from-pac
But it only has 1 vote. Send it some love and see if we can get some more votes over there

Vanessa