Release is not creating automatically after pushing the packages it to Octopus server


We are using TeamCity for building packages and included step to push the packages to Octopus repository.

We can see the packages on Octopus and release is not creating automatically. We will have to create release manually. When we click trigger on this project and we are getting below error.

Cannot read property ‘Name’ of undefined

TypeError: Cannot read property ‘Name’ of undefined

TypeError: Cannot read property ‘Name’ of undefined

There is no much information on Octopus log files. Please advise on this.

Hi Ramana,

Thanks for getting in touch,

I’m sorry to hear you are experiencing this issue, I understand this behavior is frustrating.

I’ve dealt with variations of this error message in the past, though not specific to access the Triggers area.

Can you please try the following steps;

  1. Navigate to the Octopus URL and replace app# with oldportal#

  2. This will load Octopus using the V3 UI, once in this mode, navigate to the affected Project and select Triggers

  3. The same error message should not be experienced at this stage

  4. After this screen is made available check the list of Triggers to see if any of the triggers are potentially missing a name? Or perhaps references a Tenant that is missing a name etc.

  5. If you’re able to identify the problem at this stage, you can either update or delete/re-create the trigger. Once you’ve made this change replace oldportal# with app# to see if this issue has been resolved in the V4 UI.

If this proves unhelpful, please let me know your Octopus version for further troubleshooting. It would also be valuable if you could export the affected Project and provide this here for investigation.

In this event, I’ve included a link to our documentation below regarding Exporting a Project via the Octo.exe command line tool, please find below;

The tool itself can be found in the Downloads area of our website.

I’ve also marked this conversation as private for privacy purposes.

I look forward to hearing back from you :slight_smile:

Kind Regards,


Thanks Reece Walsh for response.

I’ve tried by using old url and can see that there is no package step was selected under automatic release creation. I’ve made the change and now its working fine in v4 version url.

Appreciate your help.

Hi Ramana,

Thanks for getting back to me,

I’m glad to hear you were able to resolve this issue, and I appreciate you letting me know the outcome.

If you require any further assistance moving forward, please let me know :slight_smile:

Kind Regards,


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.