Pushing with OctoPack to Octopus Server via msbuild fails - Unable to connect to the remote server

Everything works in the same domain, however, I’m trying to have the Octopus server in a different domain but the push fails. I’m not sure what do I need to know to make this work. I have tried with and without specifying the port 10933 (just with the IP address). It is possible that the port is not open for incoming connections but will it even work without certificates even if the port was open?
I suspect I will get a strong push back if I ask our networking team to open port 80…
Is it expecting to make a PUT request over port 80?
How do you normally solve this kind of issues?

I’m on Octopus 3.12.6

     OctoPack: Successfully created package 'xxx.xxx.2017.05.09.2.nupkg'.
     OctoPack: Copy file: xxx.xxx.2017.05.09.2.nupkg
     OctoPack: OctoPack successful
     Publish to repository: http://xx.xxx.xx.xxx:10933/nuget/packages?replace=true
     "xxx\nuget.exe" push "xxx.xxx.2017.05.09.2.nupkg" API-MYOCTOPUSAPIKEY -Source http://xx.xxx.xx.xxx:10933/nuget/packages?replace=true 
     NuGet Version: (Custom build for OctoPack. See http://g.octopushq.com/VersioningInOctopusDeploy)
     Pushing xxx.xxx.2017.05.09.2.nupkg to 'http://xx.xxx.xx.xxx:10933/nuget/packages?replace=true'...
       PUT http://xx.xxx.xx.xxx:10933/nuget/packages?replace=true/
     An error was encountered when fetching 'PUT http://xx.xxx.xx.xxx:10933/nuget/packages?replace=true/'. 
    An error occurred while sending the request.
       Unable to connect to the remote server
       A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond xx.xxx.xx.xxx:10933

Thank you

Hi Arman,

Thanks for getting in touch! I see that you have a port set for your source URL set to 10933. This port is reserved for Tentacle communication.
How do you access your Octopus server from outside of the server? You should be using the same URL and port that you access the Octopus portal from.

Let me know if that helps!

Hi Vanessa,
As I already mentioned I tried with AND without specifying the port. Octopus is installed on an internal server and I just RDP to it. Ports are locked down unless I explicitly put a request to open them. Are we expecting to have the default http port (80) open on the Octopus server? That wouldn’t be a secure connection! Is there a common practice to handle these kind of situations?




Packages need to be pushed over port 80. The common practices to handle this situation are:

  • add an SSL binding to your Octopus configuration and open the SSL port
  • only open the port to trusted clients
  • use an external NuGet feed

Hope this helps.


Thank you. SSL binding worked.