Pushing of large packages to the internal feeds fails most of the time

Hello Support,

We are using nuget to push packages to the Octopus (3.3.2) internal feed

We are seeing the following errors from nuget.exe:

  • a task was cancelled
  • the http request has timed out after 100.000 milliseconds

Attached you will find the diagnostics with the error messages.

The package size is ~279MB.
We host Octopus server on an Azure VM with SQL Server express running locally.

Smaller packages do function properly. We have the idea that the problem has to do with filesize or a timeout.

Kind regards,

OctopusDeploy-636053810968037414.zip (36 KB)

HI Gjalt,

Thanks for reaching out.

When you say you are using Nuget to push packages to the Octopus (3.3.2) internal feed, I’m assuming you are using Nuget.exe Push, correct? If that’s the case, can you share me the full command you are using?

By default Nuget push should give you a 300 second timeout (5min), but according to your error message its timing out at 100k miliseconds (about 1.5min). Can you try passing the parameter -Timeout 360 to force an increased timeout and see if that works?

Nuget Push doc in case you need reference for the parameter: https://docs.nuget.org/consume/command-line-reference#push-command-examples


Hello Dalmiro,

Last week we already tried -Timout 601 for a 10 minute timeout. But that did not work.

After I posted the issue the support forum we tried rebooting the Virtual Machine.

That solved the problem for us.

It is not clear however what the root cause of the problem was.

Kind regards,


Van: Dalmiro Grañas tender2+dd2d1a8312@tenderapp.com
Verzonden: maandag 1 augustus 2016 04:29:42
Aan: Gjalt Wijma
Onderwerp: Re: Pushing of large packages to the internal feeds fails most of the time [Problems #46765]