Problems with HTTPS bindings after upgrade

Hi Octopus

After upgrade to 3.2 line we get an error from a hitherto working ssl binding. It simply states that parameters are incorrect.

The certificate is a star certificate for the domain “*” why I also specify a hostbinding ( in the specific case).

It has been working for months until the error showed up approximately a week ago. I believe it was a consequence of an update, as Octopus 3.2.1 worked. I don’t know if the problem was introduced with 3.2.2 or 3.2.3.

This is a problem as it will prevent me from performing rather essential deploys. I have tried deleting the web site on the server an performing a “clean” install, but to no avail.

Kind regards

ServerTasks-5866.log.txt (18 KB)

Sorry: It seems enabling SNI on the binding solves the problem. I am just a bit puzzled why I have only recently experienced the problem as the SNI-options has been around since 2.6, but that is of lesser importance.

Hi Morten,

This bug could be the potential cause of this issue, we changed the way we store the IIS bindings and it wasn’t 100% backwards-compatible, and the workaround was to make a change to the bindings and save it and it’ll be good again.

This was fixed in 3.2.4 to be fully backwards-compatible again.

Thank you and kind regards,