Problem after upgrading to version 3.8.7


Yesterday I was upgrading Octopus from version to 3.8.7. I followed your upgrade guide, so at first, I made the upgrade to version 2.6, and then to the newest version (with manual tentacles installation).
After upgrade to 2.6, I was able to access Octopus web portal trough local domain “deploy.xxxx”, but after upgrade to 3.8.7, it wasn’t possible (HTTP Error 503. The service is unavailable.).

On the same server, there is TeamCity server installed (which was upgraded 2 days before from version 8.1.2 to 10.0.4). After upgrade to 3.8.7, I cannot access it through local domain build.xxxx, I got the same error as for octopus: I had to add additional localhost:80 binding, which helped partially. I didn’t check it after upgrade to 2.6.

Both applications can be accessed with IP addresses. I also can make Octopus working on deploy.xxxx by adding an additional binding in Octopus Manager (localhost:80) but it cause that address build.xxxx also points to Octopus server.

I tried also clean installation of Octopus but it didn’t help.

Please let me know if you need more details.


I find what cause that problem.
I set AD user for octopus server, and Octopus suggested to run this commands:
netsh http add urlacl url=http://+:80/ user=xxx

Hi Robert,

Thanks for getting in touch! It looks like you found the solution, and got your bindings working correctly after your upgrade. Could you confirm when you applied the bindings that it resolved the issue? Don’t hesitate to get back in touch to clarify or ask any further questions!

Kind regards,