Please help with Jira Cloud Integration

I am currently running the latest Octopus Server internally, and am trying to integrate it with our Jira Cloud instance.

I add the Marketplace app to Jira with my admin account, and when I try to save the Octopus Installation ID – I click “Save” in the Octopus Deploy Configuration screen in the marketplace app – I get a blank page. My network tab in Chrome indicates an HTTP 400 Bad Request on the “JiraConnectApp” URL. The console echoes the same.

I am using Chrome, and doing this in an Incognito window. The marketplace app reports as version “1.0.3-AC”. I have uninstalled and re-installed the marketplace app multiple times. I also tried Safari since I don’t have any plugins there, in an abundance of caution, and saw the same result trying to configure the marketplace app.

On the Octopus side, when I try to test the app, I get the famous “Failed to get authentication token…” error. However, testing the “Release Note Option” config does indeed work.

I have seen a number of similar posts, but none of them seem to apply to my particular case? I’m sure I am missing something ridiculous. Please assist?

Hi @pjohnson,

Thanks for getting in touch! I’m sorry to hear you’re hitting this trouble getting the Octopus plugin working in Jira. I gave this a test locally using the same plugin version and the save of the Octopus installation ID worked as expected, which resulted in a successful connection test from the Octopus side.

We’ve seen something similar occur in cases where multiple Octopus instances were trying to connect to a single Jira subscription. Could that be applicable in your case?

From there, I’m wondering if something network-related might be unexpectedly interfering with the request headers somehow?

I hope this helps narrow down what could be happening here, and I look forward to hearing back!

Best regards,

Kenny

Hi @pjohnson,

I just wanted to touch base again to let you know I was in the end able to reproduce this issue in Chrome incognito. It turned out to be an issue with Chrome blocking third party cookies by default in Incognito. Enabling this allowed me to save the Octopus Installation ID in the Jira app. If you’re needing to this in incognito mode, you would need to enable these third party cookies, which is done by clicking the eye icon in the address bar.

Please let me know how you go and if that helps!

Best regards,

Kenny