Permission Issue

modelling

(Michael Gantz) #1

We are running Octopus version 3.3.24. I am trying to figure out what permissions are needed for someone to download a nugget package - the error we get is:

Missing permission: BuiltInFeedDownload

This is not in the list of default roles. Do I have to create a custom role for it? What permissions do I have to choose. I have tried assigning the user to a team with Project Initiator, Project Lead, Package Publisher, none have worked. I am trying to avoid Octo administrator. Does anyone know what I am missing? Any help would be appreciated. Thank you.


(Reece) #5

Hi Michael,

Thanks for getting in touch, your patience is greatly appreciated.

At this stage, we don’t have any built-in roles for the permission you require of BuiltInFeedDownload this is also true for BuiltInFeedAdminister

In this scenario, I would suggest creating a custom role for the users that need this permission, ensuring this user role has BuiltInFeedDownload as required.

There’s only 1 built-in role for feeds and it’s: Package publisher with just 1 permission BuiltInFeedPush

I hope this helps!

If I can of any further assistance, please let me know :slight_smile:

Kind Regards,

Reece


(system) #6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.