Package version **** was deleted from the built-in repository due to the package repository retention policy

(Rohit Verma) #1

Hi there,

Hope you are doing well.

We are using Octopus Deploy to as our Continous Deployment tool and currently, we are deploying some frontend packages. We have been seeing some weird behaviour from Octopus Deploy package retention policy. I pushed a package to build in repository on 7th March, 2019. We have set our package repository retention policy to 4 days. And it also says that package used in a release will not be deleted unless the release is deleted. I have used that package as a reference in one of the steps that we configured. But still, it deleted my package yesterday stating “Package UXP-Dashboard version 7151 was deleted from the built-in repository due to the package repository retention policy”. I am not sure why it is deleting the package which is being used in the release and also has reference to the step. This has happened earlier also. Not sure what is wrong here. Below are the details in the order.

1. Push Package
2019-03-07 11:31:38 AM +00:00 Package UXP-Dashboard version 7151 was pushed to the builtin feed

2. Package reference in Step.

3.Package Deployed to DEV Environment.

4. Tried to promote release from DEV to STG.

5.Audit log - Deleted Package.
2019-03-11 01:27:29 PM +00:00 Package UXP-Dashboard version 7151 was deleted from the built-in repository due to the package repository retention policy

Please suggest what is wrong here. Why is it deleting the package even if it has a referenced release created and it has separate retention policy in Lifecycle to keep last 5 releases.

Thanks.

(Rohit Verma) #2

Hello Again,

Is this something related to Package Version and Release version mismatch???

#4

Hi Rohit,

Thanks for getting in touch, and sorry it has taken so long for me to respond to this one.

The first question I have is which version of Octopus are you running, as we have had a couple of bugs recently in this area, specially this one and this one, which I consider to be the most likely one based on your screenshots.

If you are in a version that is affected can you please upgrade and advise if you are still having problems?

Sorry for the inconvenience caused,

Regards
Alex

(Rohit Verma) #5

Hey Alex,

Thanks for your response.

The version we are currently using is v2018.9.6.

It looks like these are the very same issues that we are facing. Most of our projects have script template. We have planned an upgrade next week. Hopefully it should resolve this. Thanks.

1 Like
(system) closed #6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.