Package upload info display limited by role?

Yesterday, I was working with another developer to start uploading tar.gz packages to our Octopus 3.3 server. We Googled a bit and eventually found some info on the API endpoint name, etc. Today, when I went back to my (admin) account and looked at the Library page, I was shocked to see exactly the info we needed shown right on top!

This page shows packages stored in the Octopus Server's built-in package repository. The repository accepts NuGet, zip, tar, tar gzip and tar bzip2 packages. Use the Upload package button above to add a package to the library.

Push NuGet packages using a NuGet client to add them here:

NuGet.exe push YourApp.nupkg -ApiKey <Your API Key> -Source <URL>/nuget/packages
Upload packages via the api with PowerShell:

$wc = new-object System.Net.WebClient
$wc.UploadFile("<URL>/api/packages/raw?apiKey=<Your API Key>", "")
Octopus does not allow NuGet clients to connect to this feed to retrieve packages; the feed only supports deployable packages, and does't allow NuGet packages to be consumed from Visual Studio and other tools.

Even though the other dev wasn’t admin in Octopus, we used his API key to perform the upload, and it worked fine. So the question is, why didn’t he see this extremely helpful information? His account can apparently upload packages - shouldn’t he see the message as well?

Hi Ryan,

That extended package support and upload information was only added in 3.3, you mention that your Octopus Server is 3.2, was that a typo (I assume that it is a typo as you have another support ticket about pushing large tar.gz packages)?

The extended information is shown to users with the BuiltInFeedPush permission. Could you get the dev to do a hard refresh on that page as the browser might have cached the old version.

Thank you and warm regards,

Dear Henrik,

Yes, as you mention, that was a typo. I actually fixed it just before you replied. Sorry.

The user has done a hard refresh, but still does not see the info. The user is a system administrator, but scoped to individual projects. This probably explains why he doesn’t see the info on the general Library page. Perhaps the page should show the info if they have BuiltInFeedPush on any project?

Hi Ryan,

Thanks for the extra information, it might be due to them being scoped to certain projects that the information isn’t shown. I’ve seen this issue previously in other areas of the UI.

I’ll investigate and let you know the outcome.

Thank you and best regards,

This is still not resolved. Any progress here?

Hi Ryan,

I’m very sorry, I must’ve forgotten to respond back to you about this issue. I’ve replicated the issue locally with a user that is a systems administrator but scoped to a project.

I’ve raised #2821 to have this fixed as soon as possible.

Thank you, and again, my apologies for not getting back to you when I said I would.

Hi again,

Just wanted to let you know that the fix for this issue will be part of the next release, 3.4.13.

I’m sorry for the inconvenience caused.

Thank you and best regards,

Looks great, thanks!