Package not being created on publish

I’m having trouble creating a package when publishing my web application.

Building within Visual Studio does create the package in the bin folder as it’s supposed to, so I assume the nuspec file is correct and octopack is installed correctly.

I run msbuild on my project and receive the following command and output:

C:\Windows\Microsoft.NET\Framework64\v4.0.30319>MSBuild.exe D:\xxx\xxx\xxx\xxx\xxx
.xxx\\ “/t:Rebuild” “/t:ResolveReferen
ces” “/t:_CopyWebApplication” /p:Configuration=Release /p:WebProjectOutputDir=D:\NewFolder\ /p:OutDi

IsReleaseBuild: True
IsWebApp: True
This is a Release build of a web application, so an Octopus package will be created
NuGet.exe found: D:\Workspaces\xxx\xxx\xxx\\
Project was published to: D:\Newfolder2
Copying file from “” to “D:\NewFolder\”
.CommandLine.1.6.0\tools\NuGet.exe” pack “D:\NewFolder\” -OutputDire
ctory “bin” -basePath “D:\NewFolder” -Version “1.0.0” -NoPackageAnalysis
Attempting to build package from ‘Lifetime.CrmBroker.Web.nuspec’.
Successfully created package ‘bin\My.Package.1.0.0.nupkg’.
Done Building Project “D:\xxx\xxx\xxx\xxx\\
eb\” (Rebuild;ResolveReferences;_CopyWebApplication target(s)).

However, when looking in the bin folders there is no package. Also when using publish a release within visual studio there is no package created.

What am I missing? It must be something staring me in the face. We’re excited about the idea of Octopus, but without even being able to accomplish the first stage it’s a bit of a problem.



I’ve solved my own problem. Well, not solved but realised what I was doing wrong. Which was expecting the package to be generated in the bin folder of the published website, not of the source code