Package download fails after upgrade to Octopus 2020.1.0

In preparation to upgrade out 2018.3.11 instance, I backed up and restored to a new Windows Server 2019 Azure VM. Then performed the upgrade to 2020.1.0. Everything looks fine, so I perform a test deployment which fails with the message:

The step failed: Activity failed with error 'The package MyPackageName v1.0.0.344 could not be downloaded to the package cache from Octopus Server (built-in) after making 5 attempts over a total of 0s. Make sure the package is pushed to the feed and try the deployment again. For a detailed troubleshooting guide go to'.

The package does exist, however. It is listed in the Library and exists on disk. I am also unable to download that package, or any other, using the download link in the Library. Further testing with the swagger page shows this message:

Invalid package specified. No id parameter was provided. Package was not found in the index of the built-in package repository. Package was not found on disk, although metadata was found in the built-in package repository index. This could mean that the file was manually deleted from disk after being indexed.

I tried again after uploading the hello-world.1.0.0 package. Same results.

I’m out of ideas how to troubleshoot this. Any advice would be appreciated.

Hi Daniel,

Thanks for getting in touch! I’m sorry to hear you’re hitting this unexpected behavior since the restore and upgrade. Could you try re-indexing the built-in repository and let me know if that improves things? This is done in the web portal under Library > Packages and clicking the Re-index now button.

If that doesn’t fix it, could you send us a copy of your server logs? These are located in C:\Octopus\Logs in standard installs, and it should provide a bit more information around this issue.

I look forward to hearing back and getting to the bottom of this one!

Best regards,


Kenny, re-indexing the packages did not help. I should have put that I tried to re-index them my original post.

I can upload the logs, but is there a way to do that privately? I would prefer that they remain confidential.

Hi Daniel,

Thanks for following up, and my apologies for not providing a private way to send the logs over to us. Probably the easiest way would be to email us directly at and I can grab them from there, or you can upload them on under the Support tab while logged in with your Octopus ID. Let me know if you require another option and I can get something set up if needed. :slight_smile:

Best regards,


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.