Overview does not show latest version deployed


I’ve searched the forum a little and could not find a reference to our issue.
For some of our environments, we do not see the latest version deployed in the Overview, as well as in the dashboard. Instead, we see the version previous to last.

See screenshot: Latest version deployed on EQCM_QA1 is (it is visible on ‘Recent Deployments’) , but the version seen in the Overview ribbon is Same for environment EQCM_QA4.

Your response on the issue will be much appreciated.

Hi Yasmin,

Thank you for getting in touch. We are aware of a few different issues with the dashboard, but to figure out what might be happening in your case, we need some more information. Could you please let us know which version of Octopus you’re using, are you using Channels, and if you could also please provide a couple of screenshots of the dashboard in question and the corresponding release page.

Hopefully this will help us figure out what’s going wrong.




We are using Octopus Deploy, and are not using Channels.


  1. Overview screenshot, where the versions displayed do not match last versions that were deployed (as can be seen Recent Deployments list)
  2. Screenshot of Releases page
  3. Dashboard screenshot, where we have the same issue as in the overview (do not display last versions)

Hi Yasmin,

Thanks for sending that through. Based on your version, Raven queries indexes to retrieve data, so generally this is caused by a corrupt index.

If you use the following guide, it will reset your Raven indexes, and that should fix it.

Let me know how you go!


Thanks a lot Kenneth,

Worked like a charm. We performed the DB Repair, and the issue is solved.

I appreciate your fast, efficient response!

Hi Yasmin,

Very happy to hear that fixed it for you! If you have any further questions, please let us know!