Offline Package Drop - using a package in multiple steps


I am currently reviewing the Offline Package Drop deployment target to see if it will work for us but have unfortunately encountered an issue

We have a nuget package which is use in several steps with each step passing in slightly different parameters to have a different effect. This works in our online deployments as I have enabled the Always deploy all packages re-deployment feature at the Project level. This results in the package being downloaded several times for each deployment but that is OK and works on in Online deployments

However when I try to deploy to a Offline Package Drop target the Acquire Package step fails as the nuget package already exists.

Does anyone have a workaround for this - or is there a change scheduled to handle this scenario?


Hi Greg,

Thanks for getting in touch, that sounds like it might be a bug - we should be able to handle this. I’ll try to reproduce it tomorrow and will get back to you if I need any other information.


Paul - have you had a chance to reproduce this issue?

Hi Greg,

I’m taking over the issue for Paul. I tried to reproduce the error as you described but it worked for both the online and offline versions.

  • Can you tell me what version of Octopus are you running?
  • Can you provide the full error details? i.e. the full offline drop command execution output.

I tested with the latest version of Octopus 3.2.21 so it’s possible this issue has already been fixed.

Looking forward to your reply!


Thanks Rob -
Thanks Rob – we are on 3.1.4, I’ll upgrade to the latest and let you know how I get on

UPDATE: - after upgrading Octopus Deploy to 3.2.23 I am able to create a offline drop package which contains multiple instances of the same nuget package