OctopusPackageDirectoryPath not used


I am passing OctopusPackageDirectoryPath in variables to a release but the tentacle doesn’t use it.

I can not see the variable listed in the log (in the “The following variables are available” section).

Down the log is:
2012-02-27 08:10:13 DEBUG The package has been installed to: C:\Octopus\Tentacle\Applications\EmsLib.WebUI. 2012-02-27 08:10:13 DEBUG If you would like the package to be installed to an alternative location, please specify the variable 'OctopusPackageDirectoryPath'

I just copied the name “OctopusPackageDirectoryPath” and use it with scope ALL for all of the options.

Server, tentacle versions: 0.9.620.4

Did I miss something? Any ideas?


I was having this problem and noticed that my release didn’t have this new variable attached to it.

I manually edited the db to add new variable and I was able to drop my package to the correct OctopusPackageDirectoryPath.


Bill, thank you a lot, you pointed me in the right direction.

The problem was that I created a test release then I played with it and tray to reconfigure the project.

I found out that the variables are copied from the project setting to the release during creation of the release.

That means you need to create a new release after changing variables in the project.

I think this could be easily missed by other people as well. My suggestions is
a) the variables should be copied after editing project properties
b) at least the user should get some kind of warning that these variables will not be used in the existing releases



A couple days before your post I posted the variable issue here (http://help.octopusdeploy.com/discussions/questions/85-changing-variables-after-release)

Subscribe / Post additional suggestions to it in case any changes come down the pipeline.


Thanks Pavel, as I mentioned in the post Bill linked to, I’ll include a button to update the variables. Adding a warning message as well when editing variables is a good idea.