Octopus Web Interface no Longer Accessible

reliability
server
known
(Stephen Mcintyre) #1

We’ve been having trouble with our Web Interface for almost a month now. Our original problem was that we had a version 3.8.1 installation that was basically non-responsive. It was hanging on the log-in screen most of the time. If we restarted the OD service, you could log in and access the site for a very short time (typically 10 minutes or so) and then the site would simply hang the next time you tried to view a different page.

I reached out to support and they suggested that I upgrade to the latest version as it has many fixes that would help to improve performance. I downloaded and ran the 2019.9.10 installer. Now the website simply doesn’t load. When I try to hit localhost directly on the server (or remotely) I simply get a 404 error. I have noticed in the logs that on restart the logging gets to a point that says “Updating external security groups via GroupRetriever…” and then it just stops. There’s never an error, the log just ends. I’ve also tried uninstalling and reinstalling, but the installer just stops at the exact same point. There is a message that states “Updating external security groups via GroupRetriever…” and then nothing else.

Any ideas on what we can try to get this instance up and running again?

(Tina) closed #4