Octopus ugrade issue


i try to upgrade from 2019.11.1 to latest versiyon 2021.3.(build12155)
Sql sever has been updated as 2017
After still i got error as below
So, upgraded step by step every version,
first updated to 2019.13.7
then Octopus.2020.1.22
then Octopus.2020.2.20
then Octopus.2020.3.10
from 2020.3.10 to Octopus.2020.4.272 got same error as above, so try to upgrade to Octopus.2020.4.13 to Octopus.2020.4.14.
But i’m stuck in Octopus.2020.4.14. I could not upgrade next version as Octopus.2020.4.229 or Octopus.2020.4.272.

Only below error in Octopus logs
2022-02-09 01:10:39.0466 5580 134 ERROR 134 Connection initialization failed while connecting to
Halibut.Transport.Protocol.ConnectionInitializationFailedException: Unable to write data to the transport connection: An existing connection was forcibly closed by the remote host…
—> System.IO.IOException: Unable to write data to the transport connection: An existing connection was forcibly closed by the remote host…
—> System.Net.Sockets.SocketException (10054): An existing connection was forcibly closed by the remote host.
at System.Net.Sockets.NetworkStream.Write(Byte[] buffer, Int32 offset, Int32 size)
— End of inner exception stack trace —
at System.Net.Sockets.NetworkStream.Write(Byte[] buffer, Int32 offset, Int32 size)
at System.Net.Security.SslStream.WriteSingleChunk[TWriteAdapter](TWriteAdapter writeAdapter, ReadOnlyMemory1 buffer) at System.Net.Security.SslStream.WriteAsyncInternal[TWriteAdapter](TWriteAdapter writeAdapter, ReadOnlyMemory1 buffer)
at System.Net.Security.SslStream.Write(Byte[] buffer, Int32 offset, Int32 count)
at System.IO.StreamWriter.Flush(Boolean flushStream, Boolean flushEncoder)
at Halibut.Transport.Protocol.MessageExchangeStream.SendNext()
at Halibut.Transport.Protocol.MessageExchangeProtocol.PrepareExchangeAsClient()
— End of inner exception stack trace —
at Halibut.Transport.Protocol.MessageExchangeProtocol.PrepareExchangeAsClient()
at Halibut.Transport.Protocol.MessageExchangeProtocol.ExchangeAsClient(RequestMessage request)
at Halibut.HalibutRuntime.<>c__DisplayClass39_0.b__0(MessageExchangeProtocol protocol)
at Halibut.Transport.SecureListeningClient.ExecuteTransaction(Action`1 protocolHandler, CancellationToken cancellationToken)

Thanks in advance

Hi @vciftci,

Thanks for reaching out to Octopus Support in our community forums!
Sorry to hear you’re having issues upgrading your Octopus Server.

Usually, when we see errors like: An existing connection was forcibly closed by the remote host, in the situation you’re encountering it in, it’s due to anti-virus, security protocols or permissions issues.

As Octopus changes, there may have been changes to specific requirements on the above that haven’t been accounted for by your system. Would you be able to check the Windows Event Viewer logs on that machine to see if there are any indications of what is going wrong?

Make sure the user account you’re running the installer as has permissions to the correct directories, as this can cause issues with installation.
This documentation may be helpful to make you aware of the permission requirements: Permissions for the Octopus Windows Service - Octopus Deploy.

Please let me know the results of you checking the Event Viewer logs or if you believe the install issues could be security-related.

Kind Regards,

Hi Adam;
thanks for quick response

i do not think that there is an permisson or directory issue, because upgraded five or more packages before this version.

There was only info log in event viewer as attached
event.txt (2.3 KB)

also added octopus server logs
CUsersvciftciAppDataLocalOctopusLogs.txt (11.9 KB)
OctopusServer.txt (7.6 KB)

I could not fing any log file(C:\Octopus\Logs) or error while upgrading. Is there any other suggested log file to check?

Thanks in advace

Hi @vciftci,

Thanks for providing all that information!

I don’t believe there will be any information in the Octopus Server logs as it seems like the installer is having the issue, rather than the Server Application itself.

Have you tried running the installer as the user account that the Octopus Service is running under? It seems quite likely that there is an anti-virus or a permissions issue stopping Octopus from creating or modifying a directory.

I had a look at the changelogs between the versions that you encountered the issue on but I can’t find any “breaking changes” or large features that would indicate a file system change but it’s still possible that the installer is trying to modify something that it lacks permissions for or is being denied by AV.

Could you double-check with your security/ops team to see if there are any possible conflicts?

I’m looking forward to hearing back!

Kind Regards,

Hi Adam,

I’ll check with our security team and I’ll let you know



Hi Adam,

ther is a policy that blocked unsigned powershell script in AD. Status of policy is changed as deny.
and it works

Thank you

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.