Octopus.Server.exe does not work

While trying to switch to Active Directory authentication I get an error (see below) while following the instructions.
The service does not stop and when I use the start command the service does not start. If I use the Octopus Manager, starting and stopping does work perfectly.
I looked in the logfile and I do not find any line showing an attempt to stop (or start). Even with the trace option enabled.

When the service stop instruction did not work I stopped trying the configure and admin commands.

Do I need to add some directories to the %path% ? Or do I miss some other environment setting ?
What to check next?

C:\Program Files\Octopus Deploy\Octopus>Octopus.Server.exe service --stop
Octopus Deploy: Server version

Stopping service...
Error: Kan de service OctopusDeploy op de computer . niet openen.
Full error details are available in the log files.
See: http://g.octopushq.com/LogFiles

C:\Program Files\Octopus Deploy\Octopus>

translation of the Dutch Error: Cannot open the service OctopusDeploy on computer .

Hi Giel,

Thanks for getting in touch! Are you using a custom instance name, or just the (Default) instance? You can check this by looking in the top right corner of the window in Octopus Manager.

If you are using a custom instance name, you’ll need to specify that using:

octopus.server.exe ..... --instance=YourInstanceName


No we do not use an instance name, it just says ‘(Default)’


Van: Paul Stovell [mailto:tender2+d5cf43479d9debaed92cbd637cef0329acfad6221@tenderapp.com]
Verzonden: vrijdag 27 juni 2014 3:09
Aan: Giel Scharff
Onderwerp: Re: Octopus.Server.exe does not work [Problems #22357]

Thanks Giel, are there any errors in the Windows event viewer? And when you run the command, are you running it from an elevated (administrator) command prompt?



That’s it !
I did not run it from an elevated command prompt.
Now it works as expected.

I did not understand that from the instructions. With ‘from an administrative command prompt’ you mean:
Start cmd.exe as administrator.

Thanks a lot.


Van: Paul Stovell [mailto:tender2+d5cf43479d9debaed92cbd637cef0329acfad6221@tenderapp.com]
Verzonden: vrijdag 27 juni 2014 11:08
Aan: Giel Scharff
Onderwerp: Re: Octopus.Server.exe does not work [Problems #22357]

Hi Guys,

I am getting a similar error. Our custom instance name is “OctopusDeploy” so

C:\Program Files\Octopus Deploy\Octopus>Octopus.Server.exe service --stop --ins
tance “OctopusDeploy” works fine but as soon as I run the following command to change authentication it fails.

Octopus.Server.exe configure --webAuthenticationScheme=IntegratedWindowsAuthentication --instance “OctopusDeploy”

I will figure it out but any help would be appreciated.


Thanks for reaching out. Couple of questions:

-What error are you seeing exactly?

  • Is it con the command prompt or on the web browser?
  • Which version of Octopus are you running?



It’s version 3. Output is below: I am trying to change authentication mode from forms authentication to integrated mode so AD users don’t have to provide credentials based on article in:

C:\Program Files\Octopus Deploy\Octopus>Octopus.Server.exe configure --webAuthen
Octopus Deploy: Server version

Error: Unrecognized command line arguments: --webAuthenticationScheme=Integrated

Full error details are available in the log files.
At: C:\Users\hotit\AppData\Local\Octopus\Logs
Unrecognized command line arguments: --webAuthenticationScheme=IntegratedWindows


This command was introduced in 3.0.13: https://github.com/OctopusDeploy/Issues/issues/1848

You need to upgrade to that version to be able to use it.