Octopus.min.js:19 Unknown deployment type: undefined

When trying to save a change to a deployment step i get the following javascript error and changes are not saved :

octopus.min.js:19 Unknown deployment type: undefined

It’s using a custom template step which multiple projects are using and don’t have this issue.

Hi Wilson,

Thanks for reaching out. Could you please help me out with the following:

  • Which version of Octopus are you running?

  • Can you send the full Javascript stack trace of the error?

  • If you delete that step and re-create it, do you get the same error?


I’m on version 3.4.11

I cannot recreate the step, i get the same error when trying to add the step.

octopus.min.js:19 Unknown deployment type: undefined
(anonymous) @ octopus.min.js:19
(anonymous) @ octopus.min.js:18
$apply @ octopus.min.js:19
(anonymous) @ octopus.min.js:24
dispatch @ octopus.min.js:7
$event.dispatch @ octopus.min.js:63
elemData.handle @ octopus.min.js:7

Hi Wilson,

  • Can you send a screenshot of the full screen where you see that JS error? We wanna get as much context as possible to attempt to repro.

  • Is there any chance you can send us the full error from the browser’s javascript console? If its the exact same that you already sent, just let me know.

  • From your browser’s development tools, can you see any failed HTTP requests?

  • If you create a brand new project, do you get the same error?


I made a change to the template then updated it in the project and it’s now working again.

I was getting the same issue when creating a new project which included the template step.

Ok so this is happening only when you use a specific step template? If that’s the case, can you send us that template so we can see what’s wrong in it? you shouldn’t be getting a JavaScript error from a step template.

Updating the template seemed to fix the issue (even though i didn’t actually change anything). I could give you the export of the template but it’s working now, is there a way to get the old version?

I’m afraid that’s not possible. If you ever get that JS error again from a template, please let us know and send us the export.


I am also getting this error with two of my step template definitions when trying to save them in a deployment project.

I have attached a screenshot of the Chrome debugger after hitting save. I have also attached the step template definition.

I am running Octopus Deploy 3.7.10.

DeployWebMaintenancePage.json (3 KB)

Thanks for bringing this issue to our attention. We have pinpointed where the exception appears to be getting raised and it seems as though the validation process is not accommodating the the default deployment type which should be falling back to WebSite.
A fix for this issue should go out in the next 3.7.12 release sometime today. Please feel free to update to this version when it is available and let me know if you continue to experience this issue.
Thanks again,