Octopus Migration Error since 3.16.2

(nik.grigoriadis) #1

I’m in the process of writing a Azure ARM template for our Octopus server and have been using the Migrator to move the data across to the new VM. Since the latest release I started getting an error with authentication-googleapps.

Some background:

  1. The source server is on the latest version 3.16.2
  2. We do not use googleapps

The error is attached!

Not sure if this is a bug or not but it’s stopping us moving our server to a new box. Any help you can provide would be much appreciated.

OctopusSupportRequest_1.txt (9 KB)

(Michael Richardson) #2

Hi Nik,

I’m sorry you’ve encountered this error.

It seems we have introduced a bug importing data from the ExtensionConfiguration table.
I have created an issue, and commited a fix for this which will ship with our next release (3.16.3) in the next day or so.

In the meantime, if you are certain you are not using Google Apps authentication, then you can delete that record from the ExtensionConfiguration table with ID authentication-googleapps in the source Octopus database.

We sincerely apologize for any inconvenience.

Regards,
Michael

Octopus.Migrator no longer supports ExtensionConfigurations
(system) closed #4