Octopus External feed doesn't find all packages

Hello

We are using Octopus version: 2022.1 (2584)

We are using Artifactory version: 5.2.1 rev 50040

We are currently looking to pull artefacts from our artifactory feed.

We find that only certain packages are being seen when tested:

These are ones in a PreRelease folder
NUPKG packages

We would like to be able to pick up packages in various folders as well as zip files but we simply cannot see those files.

When we set up a feed with the additional folder name such "https://artifactory/repo/project/foldername, we get an error:

Unhandled error on request: “The V2 feed at ‘https://artifactory.server.net/artifactory/api/nuget/snapshots-local/Search()?$filter=IsAbsoluteLatestVersion&searchTerm=‘a’&targetFramework=’’&includePrerelease=true&$skip=0&$top=10&semVerLevel=2.0.0’ returned an unexpected status code ‘404 Not Found’.”

It seems in the search it is trying to look for a folder named prerelease which doesn’t exist in here?

is this normal? How can we tell Octopus to look in all folders and not just look for prerelease

Thank you


Just to add I have looked at the post: External Feed Could Not Find The ZIP Format Package From Jfrog Artifactory

I have tried to add a nupkg package to a folder outside of Prerelease but it still doesn’t find it


I have moved my test nupkg to prerelease and now it is visible in octopus feed

Hi @supafly270,

Thanks for getting in touch!

If possible it would be good to approach each issue individually, that way we can be clear there’s no confusion between different file/feed types.

ZIP Files
In order to retrieve zip files from an artifactory feed using an external feed within Octopus, you should use a Maven feed from within Octopus.
As mentioned in the post that you linked, maven requirements will need to be met for this to work correctly.

NuGet packages not found
In some cases NuGet packages aren’t found by a feed due to them being missing from the index.json inside the feed.
We have a great troubleshooting guide for NuGet feeds, if you haven’t seen it already, which goes into detail about this: NuGet Feeds - Troubleshooting.
A good test for this could be to see if the package can be pulled from the feed outside of Octopus, or to pull the index.json from the feed and inspect it to see if the package is listed correctly.

I noticed you mentioned certain paths causing an issue and when you moved a package to a different folder it was retrievable from the feed, I’m not certain the cause of this, would you be able to go into more details, please?

I hope this information is helpful, please let me know if I’ve missed anything or if I’ve misunderstood any details you’ve provided.

Kind Regards,
Adam