Octopus CLI latest 404 error

Hi Team,

On Azure DevOps server we are using the “Create Octopus Release” step as a part of our automatic deployment process. However a few days ago we started receiving this error:

Attempting to contact https://g.octopushq.com to find Octopus CLI tool version latest

##[error]Error: Request timeout: /octopus-tools/latest.json

##[debug]Processed: ##vso[task.issue type=error;]Error: Request timeout: /octopus-tools/latest.json

##[error]Error: Unable to locate and download the latest Octopus CLI tool. To use the embedded copy or another specific version, add the Octopus CLI installer task to the build pipeline before this task.

I tried the url https://g.octopushq.com/octopus-tools/latest.json from my browser and I got an error 404. Is it possible to make this link work again? I have tried this on different networks so a network issue on my side is ruled out.

I know that I can add the “Octopus CLI Installer” task but I would like to avoid adding it to like 30 build definitions.



Hi @gszalai,

Thanks for getting in touch!

There is a redirect configured on that URL (https://g.octopushq.com/) so that the actual URL being used to check the CLI version would be https://download.octopusdeploy.com/octopus-tools/latest.json

Do you have any kind of whitelisting enabled that could be blocking this redirected URL?


Hi Paul,

whitelisting the URL you mentioned solved our issue.

Thanks for your help!


1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.