Octopus 2.6 tentacles automatically revert to 2.4 when the machine reboots

I installed the stable release of Octopus Deploy 2.6 about a couple of weeks ago. So far, most things have gone well, The upgrade of the tentacles seemed to stall on a couple of machines on the step that restarted the service, but rerunning it upgraded all of them.

We have our server reboot window in our testing environment on Tuesday nights. For the past couple of weeks, I’ve noticed that when the tentacle machines reboot, the tentacles seem to be downgraded to 2.4 again. All deployments to testing fail on Wednesday morning until I go in and upgrade all of them from the front end again.

Any ideas?

Additionally, even after I upgrade them all and the master server is happy and doing deployments, if I log into any of the tentacle machines and look at the installed programs, it still says tentacle version

Hi Brett,

Thanks for getting in touch! This is a bit of a weird one. Do you have any small environments you can run a health check on? After the reboot it would be good if you could test running a health check to see if it re-marks them as 2.6.

If you could also choose 1 or 2 machines and select the Reinstall option in the Tentacle Manager and see if they appear to ‘revert’ back after the reboot.

Let me know what you find.

Thanks for the reply! I tried both the things you suggested and it doesn’t look to have solved the issue. Reinstalling the tentacle seemed to not change the version in the installed programs section of Control Panel and after rebooting I still see the attached.
I’d imagine that completely uninstalling the tentacle and installing it via the 2.6 installer would work but we have almost a 100 tentacles and that’d be extremely tedious. Any other ideas I can try?

Hi Brett,

When you upgrade Tentacles through the Octopus interface we actually have a package, uninstall it in a new directory and re-point the service. We do not run the MSI or update the tools in this instance.
It is something that is changing for 3.0, but it was done this way as it causes the least issues with permissions and MSI installs. It also means like you said in the control panel it doesn’t update the version or path.
However what the health checks when they check the version is the version number that the Tentacle.exe binary is stamped with during the build.
So why this is reverting in some way after your restart is just bizarre. A direct MSI upgrade does also upgrade the tools and the control panel version.

We had a customer who had a completely different issue but needed to reinstall via the MSI and also had hundreds of Tentacles so we suggested using the MSI install template and package up the tentacle MSI and run it as a deployment. This is the blog post that explains the use of the template if you want to give it a try http://octopusdeploy.com/blog/install-msi-with-octopus
I am concerned though as you said, when you did a straight MSI upgrade and reinstall it didn’t update.