OctoPack URL encodes files in nupkg

I have files as part of my build that include the @ symbol.

For example: “images\findbarButton-next@2x.png”.

When OctoPack runs it creates the nupkg but the files within the nupkg seem to be URL encoded (the file is now: images/findbarButton-next%402x.png"). When leveraging them against Octopus Deploy directly it seems to translate back out during the deployment process fine. However, we also use those same packages to create offline installers (not handled by OctopusDeploy) and extracting these archives means that the file names are incorrect.

Is this a bug in OctoPack or any configuration parameter we can add to prevent the encoding of filenames like that?

Thanks!

Sorry the email filter blocked out my filename it was:

images/findbarButton-next[at]2x.png

Nevermind, this can be closed. Seems this is related to NuGet packages in general and using a regular zip utility to extract them (which is what it seems TeamCity does) is the issue. I’ll go digging in TeamCity support for a solution.