OctoPack does not trigger on Build

Installed OctoPack3.4.6 from PackageManager. OctoPack is not triggered during msbuild.
Followed online doc and video. checked csproj file and no ‘import’ exists. Tried uninstalling/reinstalling OctoPack nuget several times.
msbuild testmvc.sln /t:Build /p:RunOctoPack=true /p:Configuration=Release


Hi Tony,

Thanks for reaching out! Could you send me your full build log and screenshots of the projects that OctoPack was added to? That’ll give us a detailed look into why OctoPack isn’t getting triggered as expected.

I look forward to hearing back!


Build log and screenshot of Nuget Package Manager attached.

msbuild command:

msbuild testmvc.sln /p:RunOctoPack=true /fl

The packages.config does have octopack:

The csproj file does not have an import for Octopack.


msbuild.log (310 KB)

Hi Tony,

When you install OctoPack are there any errors reported in the Package Manager Console? I’ve tried installing OctoPack 3.4.6 and it is working as expected for me.

Could you tell me what kind of project you are trying to install it into? Is it just a plain old MVC website project?

Thank you and best regards,

Hi Henrik,

This was a plain MVC template project, just to test out OctoPack.

I tried another test project and OctoPack is packaging as expected.

Please mark this thread closed.

Thanks for your help.

Hi Tony,

Great to hear that you got your issue sorted.

Happy deployments!

Thank you and best regards,