OctoPack 2.0.26 excludes folders starting with "."

Hi there,

Not sure if this is by design but it seems that any folder which begins with a dot (eg .foo) does not get included in the resulting package.

I checked the output log and it indicates that the folder and its contents are being included, but doesn’t seem to make it to the nupkg file. I tried both setting the files to Content and including them in the actual .nuspec with the same results.

Any help appreciated!


This is the default behavior of nuget.exe and Octopack, as far as I can see, doesn’t provide a way to override this behavior.

We’ve resorted to modifying the source to allow a parameter to be passed through, to override the default.

The nuget command line option is -NoDefaultExcludes


Hi Graeme,

Thanks very much for clearing that up for me.

Is there any chance we could get ahold of your customised build?



I managed to solve this by adding /p:OctoPackNuGetArguments=-NoDefaultExcludes to the MSBuild command.